Opened 11 years ago

Closed 11 years ago

#8 closed defect (fixed)

disagreement in SAScollimation definition

Reported by: prjemian Owned by: prjemian
Priority: major Version:
Keywords: Cc:

Description

The definition of SAScollimation has some disagreement between the XSD, the block diagrams, and the various XML example and template files.

Exactly where is distance?

SAScollimation
  distance    <-- XML Schema says
  aperture
    size
      x
      y
      z
    distance  <-- other things say


Change History (3)

comment:1 Changed 11 years ago by prjemian

  • Status changed from new to assigned

comment:2 Changed 11 years ago by prjemian

As we last left this one month ago, we decided to have this substructure:

    SAScollimation
        distance
        aperture
            size
                x
                y
                z
            distance
        aperture (more of these are allowed)

This was made consistent today with changeset [26]

For a clearer view, see :

http://www.smallangles.net/wgwiki/index.php/cansas1d_SAScollimation

Things are clearly defined on this page.

The problem is that a few things have been out of synch between the block diagrams,
the XML Schema, the definition of terms, the template and other items.

Proposal

Propose a change in the name of the "distance" immediately after SAScollimation. By Steve's message on 2008-03-25, SAScollimation/distance describes the "amount/length of collimation inserted on a reactor SANS instrument." I suggest that we change
SAScollimation/distance
to
SAScollimation/length
and that will make this distinction very clear.
That is to say:

    SAScollimation
        length
        aperture
            size
                x
                y
                z
            distance
        aperture (more of these are allowed)

comment:3 Changed 11 years ago by prjemian

  • Resolution set to fixed
  • Status changed from assigned to closed

proposed change implemented as part of [27]

Note: See TracTickets for help on using tickets.